Thursday 4th June 2020

S3 Storage Maintenance, scheduled 4 months ago

A planned maintenance of our S3 Storage will take place, starting at 10:15 CEST on 04.06.2020.

Update: Our S3 Cluster is currently not available, we are working on a solution.

Update #2 12:29: Our S3 Cluster is back online again. But we expect some performance issues.

Update #3 13:06: Our S3 Cluster is fully back online now. Setting status to fixed.